Opened 9 years ago

Closed 9 years ago

#2411 closed Bug (fixed)

Anchors are not created after #2263

Reported by: Alfonso Martínez de Lizarrondo Owned by: Martin Kou
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.6.3
Component: General Version: FCKeditor 2.6.3 Beta
Keywords: Confirmed Review+ Cc:

Description

Reported in http://www.fckeditor.net/forums/viewtopic.php?f=6&t=10656

I've checked that Firefox, Opera and Safari fail to create anchors since #2263 was fixed http://rev.fckeditor.net/fckeditor/trunk/2138/_samples/ works and http://rev.fckeditor.net/fckeditor/trunk/2139/_samples/ fails

No javascript errors are generated, the <a> is created but it lacks the name attribute.

Attachments (2)

2411.patch (1.3 KB) - added by Martin Kou 9 years ago.
2411_2.patch (2.1 KB) - added by Martin Kou 9 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Changed 9 years ago by Martin Kou

Attachment: 2411.patch added

comment:2 Changed 9 years ago by Martin Kou

Keywords: Review? added

Please test for #2263 in IE with non-empty anchors as well during review.

comment:3 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

The fix looks correct, but it seems that reverting the first part of [2139] (the additions from line 124 to 130) is also correct.

comment:4 Changed 9 years ago by Alfonso Martínez de Lizarrondo

I haven't tested if it's really a bug , but maybe it's related (due to the "name" attribute). Check this report: http://www.fckeditor.net/forums/viewtopic.php?f=6&t=10674

Changed 9 years ago by Martin Kou

Attachment: 2411_2.patch added

comment:5 Changed 9 years ago by Martin Kou

Keywords: Review? added; Review- removed

comment:6 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:7 Changed 9 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [2318].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy