Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2426 closed Bug (fixed)

IE: Switching between two editors with shared toolbar does not work properly

Reported by: Mathias-S Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6.3
Component: General Version: FCKeditor 2.6.3 Beta
Keywords: Confirmed IE Review+ Cc:

Description

When using two FCKeditor instances with a shared toolbar, it is not possible to directly switch from one instance to another. One has to click either outside the editors, then on the second instance, or twice on the second instance.

To recreate:

  1. Open sample10.html or sample11.html in IE
  2. Select the first instance of FCKeditor
  3. Select the second instance

When you select the second instance, the toolbar is deactivated, and the cursor remains in the first instance. You have to click twice on the second instance to properly activate it.

The fix of #2376 is the cause of the regression. In my view, it would be best to revert that change, since it makes the use of shared toolbar practically impossible.

Attachments (1)

2426.patch (1.2 KB) - added by Martin Kou 9 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Changed 9 years ago by Martin Kou

Attachment: 2426.patch added

comment:2 Changed 9 years ago by Martin Kou

Keywords: Review? added

It turns out this is not caused by an IE bug. The brief flickering which stopped you from switching between editor instances in a single click happened because FCKSelection.Restore() was called when you tried to focus into the other editor instance. But FCKSelection.Restore() brought the focus back to where you started because the saved selection was in the first editor instance.

What my patch does is that, as long as you've brought your focus to an editable area, FCKSelection.Restore() won't do anything.

comment:3 Changed 9 years ago by Martin Kou

Keywords: Confirmed IE added
Version: FCKeditor 2.6.3 Beta

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:5 Changed 9 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [2323].

Click here for more info about our SVN system.

comment:6 Changed 9 years ago by Alfonso Martínez de Lizarrondo

this fix has caused #2496

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy