Opened 11 years ago

Closed 8 years ago

#2504 closed Bug (wontfix)

wikilinks and <br> are lost within wikilinks (version 2.5 SVN for MediaWiki)

Reported by: Peter Koppstein Owned by:
Priority: Must have (possibly next milestone) Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Cc:

Description

For example, using Build 20055, the following wikitext:

[[Image:The_Pinnacles_2003.jpg|thumb|[[wikipedia:The_Pinnacles_Desert|The Pinnacles, Western Australia]]{{wp}}<br> Notice that image metadata for uploaded images is automagically displayed on the image page? and that captions can contain hyperlinks.<br>]]

becomes:

[[Image:The Pinnacles 2003.jpg|thumb|The Pinnacles, Western Australia{{wp}} Notice that image metadata for uploaded images is automagically displayed on the image page and that captions can contain hyperlinks.]]

Change History (3)

comment:1 Changed 11 years ago by Artur Formella

Keywords: Confirmed added
Priority: HighNormal

comment:2 in reply to:  1 Changed 11 years ago by Peter Koppstein

Priority: NormalHigh

Replying to arczi:

Thanks for confirming the problem. I have changed the Priority back to "High" for the reasons explained below. I'd also appreciate it if you could leave it as "High".

The main reason for classifying it as "High" is that this bug prevents FCKeditor cannot from being used on any site which must trust it not to "break" an existing page. (I am referring of course to the breaking of wikilinks within wikilinks, not to the <br> problem, though I suspect that fixing this bug will fix related bugs as well.)

To my knowledge, this is the only outstanding FCKeditor+Mediawiki bug that will nontrivially "break" an existing page.

If there are other such bugs, please let me know (at peak@…). If there aren't any, then it's the only bug which is absolutely preventing us from making FCKeditor available on our production website!

Thank you.

comment:3 Changed 8 years ago by Krzysztof Studnik

Resolution: wontfix
Status: confirmedclosed

FCKEditor + MediaWiki is no longer supported

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy