Opened 11 years ago

Closed 7 years ago

#2559 closed New Feature (invalid)

Capability to tab within editor

Reported by: Sean McClowry Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.6.1
Keywords: Cc:

Description

Capability to tab within editor to go move text left or right, indenting. This is available in FckEditor standalone but not in the version integrated with mediawiki.

Change History (11)

comment:1 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Keywords: mediawiki removed
Milestone: FCKeditor 2.6.4

comment:2 Changed 11 years ago by Artur Formella

Keywords: Pending added

I found only one way to align text in wiki

<html>
<p style='float:right'> text [[link]] </p>
</html>

which is a bit problematic. FCKeditor shows it as an icon (<HTML>). Do you have any idea?

comment:3 Changed 11 years ago by Sean McClowry

I do not know of any way to align text other that the approach listed above. It is possible, however, to indent with a ":"

So for example: No indent :1 indent ::2 indents

comment:4 in reply to:  3 Changed 11 years ago by Sean McClowry

Replying to sean.mcclowry:

I do not know of any way to align text other that the approach listed above. It is possible, however, to indent with a ":"

So for example: No indent :1 indent ::2 indents

The syntax doesn't work here, but it does in mediawiki. Got to here: OmCollab_sandbox on MIKE2.0

comment:5 Changed 11 years ago by Artur Formella

Keywords: Confirmed added; Pending removed

Ok, it's easy to do indents.

comment:6 Changed 11 years ago by Artur Formella

There is other way to align text. It is described in ticket #2161

comment:7 Changed 11 years ago by Artur Formella

#2559 has been marked as DUP.

comment:8 Changed 11 years ago by Sean McClowry

Thanks. Yes, this is what I typically do when working directly in wikitext. e.g. http://mike2.openmethodology.org/w/index.php?title=MIKE2.0_Methodology&action=edit

Are you thinking of creating a div placement button within fckeditor? That would be really great.

comment:9 Changed 11 years ago by Sean McClowry

Actually, I now see that this functionality already exists.

If I go to fckeditor_config and uncomment ['JustifyLeft','JustifyCenter','JustifyRight','JustifyFull'],

Unfortunately, it does not seem to work. I can justify the text in the browser but when I go to save it disappears.

comment:10 Changed 11 years ago by Artur Formella

It is true. Those buttons add HTML code. MediaWiki doesn't understand it, that's why we need to do it in other way.

comment:11 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: confirmedclosed

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy