Opened 11 years ago

Closed 7 years ago

#2560 closed Bug (wontfix)

Background color applied to Text in IE when I select all

Reported by: murray5 Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4
Keywords: IE Cc:

Description

If I have a background color set in my css, then I go Select All, and then type and then save. The background color gets applied to all my text with <font style="background-color:(a color);">my text</font>.

This only happens in IE, firefox it does not.

I have made a work around for this, attached is the plugin I wrote the does the select all pretty well.

Attachments (1)

fckplugin.js (2.1 KB) - added by murray5 11 years ago.
Plugin for select all work around.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by murray5

Attachment: fckplugin.js added

Plugin for select all work around.

comment:1 Changed 11 years ago by Artur Formella

Keywords: Confirmed IE HasPatch added

Steps to reproduce:

-Set body background in CSS file

body {background-color:#dddddd}

-Reload fckeditor

-Select all (CTRL+A)

-Type 'a' (without backspace)

-Back to source:

in IE7: <p><font style="background-color: #dddddd">a</font></p>

int FF3,Safari: <p>a</p>

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Component: Core : StylesGeneral

comment:3 Changed 7 years ago by Jakub Ś

Keywords: HasPatch removed
Resolution: wontfix
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy