Opened 11 years ago

Closed 8 years ago

#2570 closed Bug (worksforme)

"align" attribute on Images breaks image dialog and context menu

Reported by: mucter Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5
Keywords: Confirmed Safari? Cc: fabrice.marchon@…, Matt

Description (last modified by Alfonso Martínez de Lizarrondo)

I have verified on the nightly build that this is still broken.

  1. Add an Image to html using the Image dialog
  2. Re-open the image dialog and set the Image's "Align" to "left" using the drop down in the image dialog.
  3. Close the dialog and right click on the image
  4. Image properties will be missing from the menu and you can't click the image dialog button to pre-populate the dialog with the selected image's info

This problem shows itself in Safari 3 on Windows and Mac and also Google Chrome, I'm not sure if it happens in Safari 2, but I'd imagine so.

Attachments (1)

2570.patch (2.1 KB) - added by Alfonso Martínez de Lizarrondo 10 years ago.
Testcase for V3

Download all attachments as: .zip

Change History (12)

comment:1 Changed 11 years ago by Artur Formella

Summary: [Webkit] "align" attribute on Images breaks image dialog and context menu"align" attribute on Images breaks image dialog and context menu
Version: FCKeditor 2.6.3

Confirmed in Safari 3 and Google Chrome (Vista32)

comment:2 Changed 11 years ago by Artur Formella

Keywords: Confirmed added

comment:3 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Component: UI : DialogsGeneral
Description: modified (diff)
Milestone: Safari Compatibility

I guess that this is due to http://dev.fckeditor.net/ticket/58 (btw, Safari 2 isn't supported in FCKeditor)

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Safari added

comment:5 Changed 11 years ago by Fabrice Marchon

Cc: fabrice.marchon@… added
Version: FCKeditor 2.6.3

I confirm the same behaviour but not in all cases with Safari (tested with version s 3.1 and 3.2) and the fckeditor 2.6.3 demo.

a) When the image is placed alone into a paragraph and aligned, the Images properties is shown.
b) When the image is placed into a paragraph with existing text and aligned, the Images properties is not shown, because the selection seems to apply over the surrounding element and not over the image itself.
c) In point b), it depends on the image alignement and its position into the text, because of the rendering of elements.

Here is the hmtl code I used for my tests:

<p>Une image seule align&eacute;e &agrave; droite: Images props ok!</p>
<p><img align="right" alt="" src="http://www.fckeditor.net/_userfiles/image/FCKeditor.png" /></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>Une image align&eacute;e en haut apr&egrave;s un texte:&nbsp;Images props ok!</p>
<p>Un texte pr&eacute;c&eacute;dant l'image ci-contre avec br<br />
<img align="right" alt="" src="http://www.fckeditor.net/_userfiles/image/FCKeditor.png" /></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>Une image align&eacute;e en haut apr&egrave;s un texte:&nbsp;Images props does not work!</p>
<p>Un texte pr&eacute;c&eacute;dant l'image ci-contre sans br &nbsp; <img align="right" alt="" src="http://www.fckeditor.net/_userfiles/image/FCKeditor.png" /></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>Une image align&eacute;e au milieu d'un texte:&nbsp;Images props ok!</p>
<p>Un texte qui pr&eacute;c&egrave;de l'image. <img align="middle" alt="" src="http://www.fckeditor.net/_userfiles/image/FCKeditor.png" />  Un texte qui suit l'image.</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>Une image align&eacute;e &agrave; droite d'un texte:&nbsp;Images props does not work!</p>
<p>Un texte qui pr&eacute;c&egrave;de l'image. <img align="right" alt="" src="http://www.fckeditor.net/_userfiles/image/FCKeditor.png" />  Un texte qui suit l'image.</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>Une image align&eacute;e &agrave; gauche d'un texte:&nbsp;Images props does not work!</p>
<p>Un texte qui pr&eacute;c&egrave;de l'image. <img align="left" alt="" src="http://www.fckeditor.net/_userfiles/image/FCKeditor.png" />  Un texte qui suit l'image.</p>
<p>&nbsp;</p>

I hope it will help you.

comment:6 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Version: FCKeditor 2.6.3FCKeditor 2.5

Changed 10 years ago by Alfonso Martínez de Lizarrondo

Attachment: 2570.patch added

Testcase for V3

comment:7 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review? added
Owner: set to Alfonso Martínez de Lizarrondo
Status: newassigned

The attachment is a proposed testcase for this issue for V3. At the same time, it says that there is no selected element in Opera right after selecting the test image (without any floating). That's a different issue.

comment:8 Changed 10 years ago by Alfonso Martínez de Lizarrondo

#3765 has been marked as dup

comment:9 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Cc: Matt added

#5101 has been marked as dup

comment:10 Changed 9 years ago by Dmitriy

any progress with this problem?

comment:11 Changed 8 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: reviewclosed

I can't reproduce this issues anymore. Seems to be outdated.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy