Opened 10 years ago

Closed 6 years ago

#2598 closed Bug (invalid)

Image Properties Dialog not applying BodyClass to Image Preview body element.

Reported by: Pauline Perren Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: FCKeditor 2.6.3
Keywords: Cc:

Description

The Image Preview textarea in the Image Properties dialog doesn't have any classes associated with the body element for the preview pane. This can mean that the preview is unviewable and may not match the site's theme.

This can be fixed by adding the line:

document.body.className = FCKConfig.BodyClass;

In the window.onLoad function in the file: editor/dialog/fck_imagefck_image_preview.html.

I'm not a javascript programmer though and I haven't looked very deeply into the code for this application so it might not be the best way.

Attachments (1)

Image Properties.png (29.1 KB) - added by Pauline Perren 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by Pauline Perren

Attachment: Image Properties.png added

comment:1 Changed 10 years ago by Artur Formella

Keywords: Confirmed added

comment:2 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: confirmedclosed

The preview is only to show the image and its properties. Image can be seen in real environment in the editor. In fact, in the new image2 plugin we haven't implemented preview at all, because it doesn't make sense.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy