Opened 9 years ago

Closed 5 years ago

#2606 closed Bug (wontfix)

Deleting a button (Safari) adds text-align: center to remaining contents

Reported by: Andrew Owned by: Dmiry Polyakov
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.3.3
Keywords: Confirmed HasPatch Safari Cc: misc@…

Description

To reproduce (in Safari):

All the remaining content in the Fckeditor box is now center aligned thanks to "text-align: center" being added to the <P> tag. We've found this to be incredibly confusing to explain to the end users, even though clicking the "Left Justify" button restores the proper left alignment. Our application relies on a lot of buttons, so this becomes an issue for us more than normal.

Attachments (2)

ticket2606.patch (2.0 KB) - added by Dmiry Polyakov 9 years ago.
Patch to fix Ticket #2606 (Deleting a button (Safari) adds text-align: center to remaining contents)
ticket2606.2.patch (2.3 KB) - added by Dmiry Polyakov 9 years ago.
Patch to fix Ticket #2606 (Deleting a button (Safari) adds text-align: center to remaining contents) - v.2

Download all attachments as: .zip

Change History (12)

comment:1 Changed 9 years ago by Artur Formella

Keywords: Confirmed added; safari text-align removed
Version: SVNFCKeditor 2.3.3

comment:2 Changed 9 years ago by Dmiry Polyakov

Cc: misc@… added
Owner: set to Dmiry Polyakov
Status: newassigned

comment:3 Changed 9 years ago by Dmiry Polyakov

I will provide a solution soon. I have it tested, just want to make sure and check it with Google Chrome - this is basically webkit problem.

Changed 9 years ago by Dmiry Polyakov

Attachment: ticket2606.patch added

Patch to fix Ticket #2606 (Deleting a button (Safari) adds text-align: center to remaining contents)

comment:4 Changed 9 years ago by Dmiry Polyakov

Resolution: fixed
Status: assignedclosed

i've added patch for version 2.6 (classes/fckenterkey.js). i've also tried to update 2.6 branch in svn, but it seems like i'm not allowed to mess with it.

Changed 9 years ago by Dmiry Polyakov

Attachment: ticket2606.2.patch added

Patch to fix Ticket #2606 (Deleting a button (Safari) adds text-align: center to remaining contents) - v.2

comment:5 Changed 9 years ago by Dmiry Polyakov

I've updated patch and now it seems to work pretty good. Also, it works ok and makes deletion better for FireFox and Opera (especially - <button> tag), just change condition to .IsGekoLike instead of .IsSafari. Fix code marked with comment: fix for webkit-based browsers (http://dev.fckeditor.net/ticket/2606) - deletes button

comment:6 Changed 9 years ago by Artur Formella

Keywords: HasPatch added
Resolution: fixed
Status: closedreopened

I added HasPatch tag. It means a patch is provided.

More about tickets: http://dev.fckeditor.net/wiki/TicketLifeCycle

comment:7 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Safari added
Milestone: Safari CompatibilityCKEditor 3.0

@dmitryx, I haven't looked at your code throughly, but it looks like a good solution.

In any case, this bug impacts on quite a few users (Safari users + users that use form elements). It makes me think that maybe we can wait for V3 to implement it, so we avoid getting the current code (more) bloated. In V3, the fix could be part of the "forms" plugin, isolating it to those who really need it (V3 will be strongly plugin based).

comment:8 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.x

comment:9 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

Milestone CKEditor 3.x deleted

comment:10 Changed 5 years ago by Jakub Ś

Resolution: wontfix
Status: reopenedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Works in CKEditor.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy