Opened 11 years ago

Closed 11 years ago

#2614 closed Bug (invalid)

sugesstion for .htaccess file with output charset definitions in it.

Reported by: Alex Troll Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

There is some apache directives on some hosting providers which suggest regional charsets on content-type output on default like:

"Content-Type:  application/x-javascript; charset=windows-1251 (BOM UTF-8)
Vary:   accept-charset, user-agent"

Which crashes firefox, opera etc. non MS browsers, cause it now contains some illegal simbols in javascripts. I suggest to include some .htaccess file for it

AddDefaultCharset utf-8
AddCharset utf-8 *
<IfModule mod_charset.c>
   CharsetSourceEnc utf-8
   CharsetDefault utf-8
</IfModule>

it will produce Content-Type: application/x-javascript (BOM UTF-8)

(terribly sorry for my english)

Change History (1)

comment:1 Changed 11 years ago by Artur Formella

Resolution: invalid
Status: newclosed

It is not a bug but a problem with integration with windows-1251 site. Isn't it?

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy