Opened 10 years ago

Closed 7 years ago

#2615 closed Bug (wontfix)

Bug in FF when FCKConfig.StartupShowBlocks=true on a hidden FCKEditor instance

Reported by: fournaise Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.3.2
Keywords: Cc:

Description

<form method="post" action="#">          
            <div id="div1" style="display:none">
		<script type="text/javascript">
<!--

var oFCKeditor = new FCKeditor( 'FCKeditor_2' ) ;
oFCKeditor.BasePath	= '/www.lib/fckeditor.release/' ;
oFCKeditor.Config['CustomConfigurationsPath'] = '/testfckeditorshare/fckconfig_HTML2.js?' + ( new Date() * 1 ) ;
oFCKeditor.Height = 100 ;
oFCKeditor.Value = '<p>This is some <strong>sample text<\/strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor<\/a>.<\/p>' ;
oFCKeditor.Create() ;
//-->
		</script>
		</div>
</form>
<input type="button" value="toogle visible" onclick="document.getElementById('div1').style.display='block'">

Error in Firebug (under FF3):

FCK.EditorWindow.getSelection() is null [Break on this error] var FCKShowBlockCommand=function(A,B){th...e()!=this._SavedState) this.Execute();};

Error fckeditorcode_gecko.js line 71.

Apparently FCKEditor needs to work on visible elements to apply "show block" on startup.

Attachments (1)

2615.htm (1.0 KB) - added by Artur Formella 10 years ago.
test file

Download all attachments as: .zip

Change History (4)

comment:1 Changed 10 years ago by Artur Formella

Milestone: FCKeditor 2.6.4
Version: SVN

Changed 10 years ago by Artur Formella

Attachment: 2615.htm added

test file

comment:2 Changed 10 years ago by Artur Formella

Keywords: Confirmed added
Version: FCKeditor 2.3.2

Confirmed in Mozilla 3 and Safari (Vista32). In IE works fine.

comment:3 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

This works in CKEditor.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy