Opened 9 years ago

Closed 9 years ago

#2616 closed Bug (fixed)

IE sometimes still insert at the beginning

Reported by: Alfonso Martínez de Lizarrondo Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: FCKeditor 2.6.4
Component: General Version:
Keywords: IE Review+ Cc:

Description

Despite the previous fixes for the 2.6.4 milestone, in the current SVN there are still some situations where IE can insert the new content at the beggining. One example is using the easyupload file dialog: http://martinezdelizarrondo.com/easyupload

For the moment this is the best option that I've found:

  • fckdialog.html

     
    697697
    698698                if ( frmMain.Ok && frmMain.Ok() )
    699699                        CloseDialog() ;
    700                 else
    701                         frmMain.focus() ;
    702700        } ;
    703701
    704702        window.Cancel = function( dontFireChange )

Attachments (1)

2616.patch (1.9 KB) - added by Alfonso Martínez de Lizarrondo 9 years ago.
Proposed patch

Download all attachments as: .zip

Change History (4)

comment:1 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: IE Review? added; Discussion removed
Owner: set to Alfonso Martínez de Lizarrondo
Status: newassigned

The problem is related to #2376, disabling the automatic save of selection also fixes the problem, so I've tested another approach that seems to work well: while a dialog is active, ignore any further automatic saving of the selection.

The fact is that debugging the calls to FCKSelection.Save, it can be seen that it's called three times whenever a dialog opens, and we just need one, any change of the selection while the dialog is open is an undesired one and should be ignored, so I added a variable to lock the stored selection.

Changed 9 years ago by Alfonso Martínez de Lizarrondo

Attachment: 2616.patch added

Proposed patch

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:3 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: assignedclosed

Fixed with [2613]

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy