Opened 11 years ago

Closed 8 years ago

#2648 closed Bug (worksforme)

Indent/Outdent kills nested contents

Reported by: Dongqiang Bai Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: FCKeditor 2.5 Beta
Keywords: Cc: bai@…

Description

Steps to reproduce

  1. Load following code into source view:
    <ul>
        <li>item1</li>
        <ul>
            <ul>
                <li>item2</li>
            </ul>
        </ul>
        <li>item3</li>
    </ul>
    
  2. Back to WYSIWYG, outdent "item3".

Expected behavior

The following code is the expected result:

<ul>
    <li>item1</li>
    <ul>
        <ul>
            <li>item2</li>
        </ul>
    </ul>
</ul>
item3

Current behavior

The "item2" will disappear. The source view shows:

<UL>
    <LI>item1 </LI>
</UL>
item3

Browsers

IE, Firefox, Chrome, Safari

Additions

The "item2" also disappears when you do indent at "item3" or "item1".

Change History (3)

comment:1 Changed 11 years ago by Dongqiang Bai

Cc: bai@… added

comment:2 Changed 11 years ago by Artur Formella

Keywords: Confirmed added
Version: FCKeditor 2.6.3FCKeditor 2.5 Beta

comment:3 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy