Opened 11 years ago

Closed 11 years ago

#2649 closed Bug (fixed)

IE: Error on Find dialog with "match whole word"

Reported by: Frederico Caldeira Knabben Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6.4
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Review+ Cc:

Description

Steps to Reproduce

  1. In the editing area, type "hello you hello".
  2. Open the "Find" dialog.
  3. Check the "Match whole word" option.
  4. Type "hello" in the find field.
  5. Click on "Find".

A JavaScript error is thrown.

It looks like an IE only issue. Works well with Firefox.

Attachments (2)

2649.patch (1.1 KB) - added by Martin Kou 11 years ago.
2649_2.patch (1.3 KB) - added by Martin Kou 11 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 11 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Changed 11 years ago by Martin Kou

Attachment: 2649.patch added

comment:2 Changed 11 years ago by Martin Kou

Keywords: Review? added

comment:3 Changed 11 years ago by Martin Kou

Milestone: FCKeditor 2.6.4

I guess we can put this in 2.6.4, the fix is very simple.

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

This fix makes no difference for me. I still have the same error.

When opening the debugger, the error happens at line 145 of fck_replace.html because "curNode" is null ('length' is null or not an object).

comment:5 Changed 11 years ago by Martin Kou

Keywords: Review? added; Review- removed

Ok, there are actually two possible errors there:

  1. When the search item is at exactly the end of the document, which was fixed in the first patch.
  2. When the search item is at exactly the beginning of the document, which is what's missing in the first patch.

Alright... posting updated patch for problem 2.

Changed 11 years ago by Martin Kou

Attachment: 2649_2.patch added

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:7 Changed 11 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [2778].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy