Opened 10 years ago

Closed 8 years ago

#2669 closed Bug (worksforme)

while drag and drop of ImageButton ,the path will be changed to absolute path

Reported by: Gobinath Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4
Keywords: IE7 Cc:

Description

while drag and drop of ImageButton ,the path will be changed to absolute path. Example while loading the imagebutton from server,in the source view the path will be like"images/gobi.gif".After that drag and drop of that image inside the editor,the source view that particular imagebutton source is chaned to "www.fckeditor.net/images/gobi.gif".In the case of image the path is not changed. Please check this one.

Change History (6)

comment:1 in reply to:  description Changed 10 years ago by Gobinath

While drag and drop of ImageButton ,the path will be changed to absolute path. Example while loading the imagebutton from server,in the source view the path will be like"images/gobi.gif".After that drag and drop of that image inside the editor,the source view that particular imagebutton source is chaned to "www.fckeditor.net/images/gobi.gif".

Image is working correctly. I want to know drag and drop of imagebutton is working correctly ,but source view only changed the file path to projects absolute path. In my project,this is the problem. Please check this one and reply me. thanks.

comment:2 Changed 10 years ago by Artur Formella

Keywords: Confirmed IE7 added

Confirmed in IE7

comment:3 Changed 10 years ago by Artur Formella

Version: FCKeditor 2.6.3FCKeditor 2.4

comment:4 Changed 10 years ago by Gobinath

i have changed fckxhtml.js .now it works...Is it correct or not...

IE doens't see the value attribute as an attribute for the <INPUT> tag. FCKXHtml.TagProcessorsinput? = function( node, htmlNode ) {

if ( htmlNode.name )

FCKXHtml._AppendAttribute( node, 'name', htmlNode.name ) ;

if ( htmlNode.value && !node.attributes.getNamedItem( 'value' ) )

FCKXHtml._AppendAttribute( node, 'value', htmlNode.value ) ;

if ( !node.attributes.getNamedItem( 'type' ) )

FCKXHtml._AppendAttribute( node, 'type', 'text' ) ;

Added by Gobi on 20081125. if ( node.attributes.getNamedItem( 'src' ) ){

var sSavedUrl = htmlNode.getAttribute( '_fcksavedurl' ) ; FCKXHtml._AppendAttribute( node, 'src', sSavedUrl ) ;

}

return node ;

}

comment:5 Changed 8 years ago by Krzysztof Studnik

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

comment:6 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy