Opened 11 years ago

Closed 10 years ago

#2686 closed Bug (duplicate)

Input Japanese for Mac Firefox

Reported by: Tomo Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.3
Keywords: HasPatch Cc:

Description

=====================================
Macbook: MB402J
OS: Mac OSX 10.5 Leopard
Browser: Firefox 3.04
Input Japanese Program: Kotoeri
=====================================

In Japanese, pressed "Return" decide word-section (Because selected KANJI). Of course, This Return is not "Break".
Now this "Return" insert "Break"(like <br>,<p>) and not necessary wods(maybe after selection).

Both IME and Kotoeri cause this bug. Only Firefox. Safari is OK.

http://positlog.org/tag/Firefox(Site)
http://positlog.org/pages/071212pG/File/fckkeystrokehandler.js.txt(Fixed)
I find this bug and how to fix in the site. The site owner said, report one of the day. But he didin't report yet.

Now, Japanes Enginer fixed myself. Please merge or fix this bug!!

Attachments (5)

img01.png (23.7 KB) - added by Tomo 11 years ago.
img02.png (22.9 KB) - added by Tomo 11 years ago.
img03.png (25.0 KB) - added by Tomo 11 years ago.
fckeditor.patch (1.3 KB) - added by snak 10 years ago.
fckeditor.2.patch (1.4 KB) - added by snak 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by Tomo

Attachment: img01.png added

Changed 11 years ago by Tomo

Attachment: img02.png added

Changed 11 years ago by Tomo

Attachment: img03.png added

Changed 10 years ago by snak

Attachment: fckeditor.patch added

comment:1 Changed 10 years ago by snak

I've attached the patch to fix this problem. On Firefox/Mac, keypress event should be used instead of keydown event, because keydown event occurs even while the input method editor is active although it should be handled inside the input method editor and should not be passed to a script.

comment:2 Changed 10 years ago by snak

Sorry, this patch disables all shortcut keys such as Command+V. I'll try looking into it later.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: HasPatch added

Changed 10 years ago by snak

Attachment: fckeditor.2.patch added

comment:4 Changed 10 years ago by snak

Here is an updated patch. It is almost same as the previous one, but handles keypress event instead of keydown event in FCKKeystrokeHandler only when it's used from FCKEnterKey. I confirmed that keystrokes which are defined in FCKEnterKey work fine even when they're handled in keypress event.

comment:5 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Resolution: duplicate
Status: newclosed

Hidekaz did create #2140. I've copied the patch by Snak there.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy