Opened 10 years ago

Closed 8 years ago

#2718 closed Bug (worksforme)

Find-replace function doesn't work properly

Reported by: Ekaterina Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6 Beta
Keywords: Cc: ekaterinas@…

Description

source code in fck-editor looks like <b>Lorem ipsum dolor sit amet</b> If I want to replace word "amet", fck stopps working. It can't replace this word. If I want to replace word Lorem, source code after replacing looks like: Lorem<b> ipsum dolor sit amet</b>

Its not only for tag <b> but also for <span>, <i>, <u>, <sub>, <sup>, <font>. Tested in your nightly version.

Next problem is <a> tag.Source code is <a href="http://www.fckeditor.net/">FCKeditor</a>. if I want to replace word editor with Lorem ipsum, source code looks like: <a href="http://www.fckeditor.net/">FCK</a>Lorem ipsum

Could you pleas fix those bugs ASAP

Change History (4)

comment:1 Changed 10 years ago by Ekaterina

Cc: ekaterinas@… added

comment:2 in reply to:  description Changed 10 years ago by Artur Formella

Keywords: Confirmed added; find-replace removed
Priority: HighNormal
Version: SVNFCKeditor 2.6 Beta

Replying to silkgirl:

source code in fck-editor looks like <b>Lorem ipsum dolor sit amet</b> If I want to replace word "amet", fck stopps working. It can't replace this word. If I want to replace word Lorem, source code after replacing looks like: Lorem<b> ipsum dolor sit amet</b>

Its not only for tag <b> but also for <span>, <i>, <u>, <sub>, <sup>, <font>. Tested in your nightly version.

What it means "fck stopps working"? I can replace all words.

Next problem is <a> tag.Source code is <a href="http://www.fckeditor.net/">FCKeditor</a>. if I want to replace word editor with Lorem ipsum, source code looks like: <a href="http://www.fckeditor.net/">FCK</a>Lorem ipsum

Confirmed in FF.

comment:3 Changed 10 years ago by Ekaterina

If you try to reproduce it in your nightly buid here http://www.fckeditor.net/nightly/fckeditor/_samples/default.html

1)Please try to replace word "text". It doesn't replace this word. 2)Than please try to replace word "sample". After replacing, this word is not bold anymore. This both problems not only for tag <b> but also for <span>, <i>, <u>, <sub>, <sup>, <font>.

comment:4 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.xClosing this issue as expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy