Opened 10 years ago

Closed 8 years ago

#2810 closed Bug (duplicate)

style attribute needs protection

Reported by: Karen Ananiev Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Every browser changes the value of the style attrubute in the way it need. I think that this attribute should be protected like src/href attributes. It will fix some already reported issues (eg. #460) and the following bug in FF:

If style attribute contains unsupported css properties, FF removes this properties after switching to wysiwyg mode. For example:

Insert this code in source mode, switch to wysiwyg mode and back to source mode.

<p style="zoom:1">This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</p>

Please, protect style attribute via _fck_style or anything.

Change History (3)

comment:1 Changed 10 years ago by Artur Formella

Keywords: Confirmed added

Confirmed, but I'm not sure we are able to fix it.

comment:2 Changed 8 years ago by Wiktor Walc

Duplicate of #5528 (the second ticket contains more information, so closing this one).

comment:3 Changed 8 years ago by Wiktor Walc

Resolution: duplicate
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy