Opened 10 years ago

Closed 10 years ago

#2814 closed Bug (fixed)

Format text across multiple table cells doesn't work right

Reported by: Andreas Hebeisen Owned by:
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: FCKeditor 2.6.4 Beta
Keywords: Confirmed Firefox Cc:

Description (last modified by Martin Kou)

The bug I describe here seems to be new since version ~2.6.3. I don't think I've seen this behavior in earlier versions.

Please fix this for the final 2.6.4 since it drives our web authors crazy. Thanks!


Browsers & OS:

  • Firefox 3.0 on Windows XP and on Mac OS X => 10.4
  • Camino 1.6 on Mac OS X >= 10.4

Browser Exception: With Safari 3.2.1 on OS X it works perfect!


Steps to reproduce:

  1. create a table withe some rows and columns
  2. fill all the cells with some text
  3. make a selection across multiple cells (click and drag, or by using the Shift- or Command-keys)
  4. Now try to format the text by using the Bold-Icon or try to assign a text color.

The result: Only the text of just one of the marked cells will be formatted while the rest remains untouched.

Below you'll find the generated HTML code. As you can see, just cell in Row 1, Column 2 (R1C2) has received the text color even though I marked more then just one cell.

<table width="200" cellspacing="1" cellpadding="1" border="1">
    <tbody>
        <tr>
            <td>R1C1</td>
            <td><span style="color: rgb(255, 0, 0);">R1C2</span></td>
        </tr>
        <tr>
            <td>R2C1</td>
            <td>R2C2</td>
        </tr>
        <tr>
            <td>R3C1</td>
            <td>R3C1</td>
        </tr>
    </tbody>
</table>

Change History (3)

comment:1 Changed 10 years ago by Martin Kou

Description: modified (diff)

Tidied up the description a bit.

comment:2 Changed 10 years ago by Martin Kou

Keywords: Confirmed Firefox added; table cells multiple text format removed
Milestone: FCKeditor 2.6.4CKEditor 3.0
Priority: HighNormal

Confirmed on Firefox (Camino is based on the same Gecko engine), ok on IE, Safari and Opera.

This is actually a fundamental design issue with FCKeditor's style system since 2.5 - it doesn't support multiple ranges in a selection. Gecko treats selections of table cells as multiple ranges, as opposed to only a single range as in other browser engines. So you have this bug in Firefox/Camino only but not other browsers.

This is not likely to be fixed in v2, but the style system we're writing for CKEditor v3 already supports multiple ranges. So I guess I'd just file this ticket under v3.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Yes, as described by Martin our new style system supports multiple ranges, so this issue has been fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy