Opened 11 years ago

Closed 6 years ago

#2834 closed Bug (fixed)

After calling GetData (GetHTML, GetXHTML) in IE6 & IE7 it is impossible to unbold text

Reported by: Sergey Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.3
Keywords: Cc: bill.echlin@…

Description

After GetData (GetHTML, GetXHTML) is called, it is impossible to unbold text, which was bolded pefore listed APIs calling. It's happen in IE6 & IE7 only. FF and Safary for windows work normal.

When "Source" button is clicked twice to show & hide sources, then unbolding is possible again, but it is not solution for my case.

Please advice something... It is used in very urgent project, which require FCK upgrade to 2.6.3 from 2.3.2. In 2.3.2 there was not such bug.

Change History (4)

comment:1 Changed 11 years ago by Artur Formella

Keywords: Confirmed added; API unbold IE removed
Priority: HighNormal

It is easy to reproduce this bug in sample08.html

comment:2 Changed 11 years ago by William Echlin

Cc: bill.echlin@… added

This is hurting us too. Would be nice to find out that a patch is in the pipe line

More Details

============

In IE the following html won't allow you to change the bold text to normal text. Possibly because the bold text isn't wrapped in paragraph marks..

<p><u>Summary</u></p>

<br />

<p><u>Test Steps</u><br /> adsf<br /> asdf</p>

<strong>dsafasdf</strong><br /> dsf<br /> adsf<br />

<p><u>Expected Results</u></p>

<br /> <!-- html -->

See the example here.....

http://test6102.traqhost.com/test_cases_modify_content.php?id=644

user: tester password: tester

WHAT DOESN'T WORK IN FCKEDITOR

===============================

If you copy the content of the QaTraq editor window (NOT THE html SOURCE but the actual html content) and paste into the fckeditor editor (http://www.fckeditor.net/demo) then the following doesn't work and you can't change the bold text to normal text

<p><u>Summary</u></p>

<br />

<p><u>Test Steps</u><br /> adsf<br /> asdf</p>

<strong>dsafasdf</strong><br /> dsf<br /> adsf<br />

<p><u>Expected Results</u></p>

<br /> <!-- html -->

WHAT DOES WORK WITH FCKEDITOR

=============================

When you view the source the FCKeditor will modify the souce automatically to the following. Once it has modified it there is no problem with removing the bold formating. Notice that there are no charachters that aren't enclosed in paragraph marks (e.g. <p></p>

<p><u>Summary</u></p>

<p><br /> &nbsp;</p>

<p><u>Test Steps</u><br /> adsf<br /> asdf</p>

<p>dsafasdf<br /> dsf<br /> adsf<br /> &nbsp;</p>

<p><u>Expected Results</u></p> <p><br /> <!-- html --></p>

INTERESTING

===========

It is interesting to note that if you have the html content in the top example in QaTraq where you can't change from bold to normal, then clicking source doesn't modify the html code at all (where as in the fckeditor demo it does modify the content). However, just the act of clicking and viewing the source, and then going back to normal view does do something to the editor so that you can change the text from blod to normal.

comment:3 Changed 10 years ago by P.J. Hinton

This is probably a duplicate of #2156, which has a description of the problem and some proposed fixes attached to it.

comment:4 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

This issue expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy