Opened 11 years ago

Closed 6 years ago

#2960 closed Bug (fixed)

plugin:pastefromword unable to re-focus preview box

Reported by: Garry Yao Owned by: Martin Kou
Priority: Normal Milestone:
Component: General Version: 3.0 Beta 2
Keywords: IE Confirmed Cc:

Description

Procedures

  1. Open the replace by code example page in IE;
  2. Click Paste from Word button to show the dialog;
  3. Click outside the preview box to blur the document;
  4. Click inside the preview box to regain focus.
  • Expected Result : The preview document is focused.
  • Actual Result : The preview document is unable to gain focus.

Attachments (1)

2960.patch (661 bytes) - added by Martin Kou 11 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 11 years ago by Martin Kou

Keywords: Confirmed added
Owner: set to Martin Kou
Status: newassigned

Actually it is possible to regain the focus, but the user has to be careful to click on the first empty row in the preview box.

Still, that's a usability bug, so needs to be fixed.

Changed 11 years ago by Martin Kou

Attachment: 2960.patch added

comment:2 Changed 11 years ago by Martin Kou

Keywords: Review? added

comment:3 Changed 11 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:4 Changed 11 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [3099].

comment:5 Changed 11 years ago by Garry Yao

Keywords: Review+ removed
Resolution: fixed
Status: closedreopened

The bug is still valid.

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.x

This issue is related to the same problem we have with #1659. Actually, it's possible to move the focus back to the field by clicking at the very top of it, but not bellow that first line.

comment:7 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Version: SVN (FCKeditor)CKEditor 3.0 Beta 2

comment:8 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

Milestone CKEditor 3.x deleted

comment:9 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reopenedclosed

I cannot reproduce this issue on master.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy