Opened 12 years ago

Closed 12 years ago

#297 closed Bug (invalid)

Missing alt="" with Smiley

Reported by: Mike Koepke Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4.1
Keywords: WorksForMe Cc:

Description

I looked into this some more and the alt="" is definitely not getting added to the img tag in FF or IE.

After looking at the fck_smiley.html source, alt is never set in the InsertSmiley function. Line 51 should read:

oImg.alt = '';

I made this change locally and alt="" is now correctly added.

Mike

Change History (3)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe Pending added
Milestone: FCKeditor 2.4.2

This is supposed to be a duplicate of #215.

Again, I repeat it here. It works for me with both FF and IE. These are my test steps:

  1. Open the online demo at http://www.fckeditor.net/demo
  2. Insert a smiley
  3. Switch to source

The alt="" is there. Actually this is not something done by the smiley dialog. The editor adds the alt attribute to any image that doesn't have it.

If you still think it is an issue, please provide us the precise steps to reproduce it.

comment:2 Changed 12 years ago by Mike Koepke

I'm sorry to be a pain about this. I found the source of the problem on my end. It is a plugin that was created to add some wordpress functionality into the editor. It appears that the plugin is hi-jacking the DIV and IMG stuff, and never chaining so that the editor gets it and inserts alt="".

Would you mind taking a quick look through the plugin to see if there is indeed a flaw or perhaps that plugin is working correctly but causes the flaw in the editor.

Mike

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Pending removed
Resolution: invalid
Status: newclosed

You should move that discussion to the forums. Thanks for the update Mike.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy