Opened 10 years ago

Closed 10 years ago

#2978 closed Bug (fixed)

Show blocks should keep state across mode switches

Reported by: Martin Kou Owned by: Martin Kou
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Review+ Cc:

Description

To reproduce the bug:

  1. Open replacebyclass.html of trunk in Firefox 3.
  2. Enable show blocks.
  3. Switch to source mode and back.
  4. Now show blocks is disabled.

Attachments (1)

2978.patch (532 bytes) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Changed 10 years ago by Martin Kou

Attachment: 2978.patch added

comment:2 Changed 10 years ago by Martin Kou

Keywords: Review? added

This is caused by a slip-of-mind logic bug in the final patch to #2869. The isOn flag should be toggled along with this.toggleState().

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:4 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [3111].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy