Opened 11 years ago

Closed 8 years ago

#2990 closed Bug (invalid)

wrong IsDirty() after GetData() execution

Reported by: Andrey Owned by:
Priority: Normal Milestone:
Component: Core : Output Data Version: FCKeditor 2.6.4
Keywords: Cc:

Description

  1. Before call of GetData() the value of IsDirty() was false.
  2. After call of GetData() the value of IsDirty() became true.

FF3. Easy to reproduce.

I think the problem in FCKXHtml.GetXHTML(). There's a function call "FCKDomTools.EnforcePaddingNode(FCKTools.GetElementDocument(A), FCKConfig.EnterMode);" which makes trouble.

I quick_fixed it by inserting "if (!D) FCK.ResetIsDirty();" after EnforcePaddingNode.

Change History (1)

comment:1 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy