Opened 10 years ago

Closed 10 years ago

#2989 closed Bug (invalid)

document::insertHtml failed in IE

Reported by: Garry Yao Owned by:
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Cc:

Description (last modified by Garry Yao)

Fuctional Testcase

test-editor-insertHtml.patch

Attachments (1)

test_editor_insertElement.patch (5.1 KB) - added by Garry Yao 10 years ago.
Updated Functional Test Case

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by Garry Yao

Keywords: IE added
Summary: document::insertHtml failed with non-initial focusdocument::insertHtml failed with non-initial focus in IE

Related to #2816

comment:2 Changed 10 years ago by Garry Yao

Summary: document::insertHtml failed with non-initial focus in IEdocument::insertHtml failed in IE

insertHtml-failed-ie.patch is obsoleted in favor of test-editor-insertHtml.patch.

comment:3 Changed 10 years ago by Garry Yao

Description: modified (diff)
Keywords: Confirmed added

comment:4 Changed 10 years ago by Garry Yao

I was able to locate the error at CKEDITOR.dom.node.insertBefore, but not sure about the reason still.

Changed 10 years ago by Garry Yao

Updated Functional Test Case

comment:5 Changed 10 years ago by Garry Yao

Resolution: invalid
Status: newclosed

Actually it's the TC's problem instead of the document::insertHtml function. TC is incorrectly written because the bug from #3192, IE need some time to move focus inside the editing document, so the updated TC should works well in IE.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy