Opened 11 years ago

Closed 11 years ago

#3021 closed Bug (fixed)

Toolbar layout is messed up in IE6 quirks mode

Reported by: Martin Kou Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Toolbar Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Oracle IE Review+ Cc: Senthil

Description

To reproduce:

  1. Delete the <!DOCTYPE> line in sample.html.
  2. Open replacebyclass.html in IE6.
  3. The toolbar is messed up.

Attachments (2)

3021.patch (40.8 KB) - added by Frederico Caldeira Knabben 11 years ago.
test-multipleclasses.patch (2.6 KB) - added by Garry Yao 11 years ago.
Functional Test Case

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by Frederico Caldeira Knabben

Cc: Senthil added
Keywords: Confirmed Oracle IE added
Owner: set to Frederico Caldeira Knabben
Status: newassigned

We are using "multiple classes selectors" in our UI CSS files. This is quite powerful as it makes the DOM structure much simpler and the CSS development much more modular.

Problem: IE has no support for this kinds of selectors when in quirks mode.

Changed 11 years ago by Frederico Caldeira Knabben

Attachment: 3021.patch added

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review? added

The proposed patch brings important changes to the DOM structure we use for UI elements:

  • All instances of "multiple classes selectors" have been removed from the CSS for toolbar elements.
  • Produces a deeper <span> hierarchy for UI elements, so we can properly select them in the CSS.
  • Introduced special class names for IE6 and IE+Quirks, so we can properly hack them into the CSS.

The patch contains a full CSS review, except for the dialog stuff.

comment:3 Changed 11 years ago by Martin Kou

Keywords: Review+ added; Review? removed

Changed 11 years ago by Garry Yao

Attachment: test-multipleclasses.patch added

Functional Test Case

comment:4 Changed 11 years ago by Garry Yao

Still have a lot of multiple classes in sight with the test case, not sure if they need to be refacted also.

comment:5 in reply to:  4 Changed 11 years ago by Frederico Caldeira Knabben

Replying to garry.yao:

Still have a lot of multiple classes in sight with the test case, not sure if they need to be refacted also.

The problem is not having multiple classes in the elements, but using the multiple classes selector in the CSS. This test is not needed.

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3208].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy