Opened 10 years ago

Closed 10 years ago

#3027 closed Bug (worksforme)

Bug edit the contents of messages containing HTML.

Reported by: Duy Tu Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6
Keywords: Cc:

Description

I copy a code html into the editer then i save it. Next I edit the this code html, it is no longer available.

  1. Add message.

http://img117.imageshack.us/img117/766/image1b.png

  1. Save message:

http://img117.imageshack.us/img117/6015/image2r.png

  1. Edit message:

http://img117.imageshack.us/img117/1993/image3j.png Is is bug.

  1. View again message:

http://img56.imageshack.us/img56/3311/image4.png

Attachments (4)

image1.PNG (8.2 KB) - added by Duy Tu 10 years ago.
Add messages
image2.PNG (5.8 KB) - added by Duy Tu 10 years ago.
Edit messages
image3.PNG (8.4 KB) - added by Duy Tu 10 years ago.
Edit messages
image4.PNG (3.4 KB) - added by Duy Tu 10 years ago.
View again messages

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by Duy Tu

Attachment: image1.PNG added

Add messages

Changed 10 years ago by Duy Tu

Attachment: image2.PNG added

Edit messages

Changed 10 years ago by Duy Tu

Attachment: image3.PNG added

Edit messages

Changed 10 years ago by Duy Tu

Attachment: image4.PNG added

View again messages

comment:1 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: edit the contents removed
Resolution: worksforme
Status: newclosed

That looks a problem with encoding (or lack of) of the < and > at the server. If you are using asp.net there was a problem about it (I think that the ticket is already closed) if you are using the javascript integration, the problem is that you aren't escaping the data.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy