Opened 11 years ago

Closed 11 years ago

#3028 closed Bug (fixed)

config:startupFocus not working

Reported by: Garry Yao Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Review+ Cc:

Description (last modified by Garry Yao)

CKEDITOR.config.startupFocus set to 'true' doesn't work for both modes.

Attachments (5)

test-config-startupFocus.patch (1.7 KB) - added by Garry Yao 11 years ago.
Functional test case
3028_light.patch (1.5 KB) - added by Artur Formella 11 years ago.
3028_heavy.patch (5.7 KB) - added by Artur Formella 11 years ago.
startupfocus_test.patch (5.0 KB) - added by Artur Formella 11 years ago.
3028_2.patch (1.4 KB) - added by Frederico Caldeira Knabben 11 years ago.

Download all attachments as: .zip

Change History (12)

Changed 11 years ago by Garry Yao

Functional test case

comment:1 Changed 11 years ago by Garry Yao

Description: modified (diff)

comment:2 Changed 11 years ago by Artur Formella

Owner: set to Artur Formella
Status: newassigned

Changed 11 years ago by Artur Formella

Attachment: 3028_light.patch added

Changed 11 years ago by Artur Formella

Attachment: 3028_heavy.patch added

Changed 11 years ago by Artur Formella

Attachment: startupfocus_test.patch added

comment:3 Changed 11 years ago by Artur Formella

Keywords: Review? added

Ok. I have 2 solutions: light and heavy. Light version sometimes works, sometimes not, sufficient in most cases. Heavy version can be used with scripts and checked with test case. I also attached startupfocus_test. It works only with "heavy" version.

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Owner: changed from Artur Formella to Frederico Caldeira Knabben
Status: assignednew
  • The "heavy" solution is concentrated on passing the test case, not really fixing this bug. The problem is that the test case has been made in a way that it depends on several other features in the editor, instead of being limited to test the issues related to this ticket. It even do that in was not supported by the editor currently. So both the test case and the patch are inappropriate.
  • Even though, the "heavy" patch proposes things that are interesting for us to have, like the "onLoad" feature. As I've pointed you in an e-mail, I would not use onLoad for that, because it still makes it not possible to register to events that happen even before the total editor load (like "pluginsLoaded", for example). I've opened #3173 for such feature.
  • I've noted that the "heavy" patch tries to fix some focus issues. If such issues have been found, please open a dedicated ticket for that. But, I would not use the "instanceReady" for any focus check, using instead the "focus" event.

The "light" solution is ok, but recent changes to the code invalidate it. I'm taking over the ticket to propose a new fix.

Changed 11 years ago by Frederico Caldeira Knabben

Attachment: 3028_2.patch added

comment:5 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed
Status: newassigned

comment:6 Changed 11 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:7 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3266].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy