Opened 9 years ago

Closed 5 years ago

#3032 closed Bug (fixed)

Event 'instanceReady' doesn't work in certain case

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone:
Component: General Version: 3.0 Beta 2
Keywords: Cc:

Description

Specifically, the instanceReady was triggered twice when edito r created in 'append' mode and the editor isn't fully interacted in because of incorrect state of 'dirty' flag.

Attachments (3)

test-editor-instanceReady.patch (2.1 KB) - added by Garry Yao 9 years ago.
Functional test case.
test-editor.patch (1.6 KB) - added by Garry Yao 9 years ago.
Updated Functiona Test Case
3032.patch (749 bytes) - added by Garry Yao 9 years ago.

Download all attachments as: .zip

Change History (13)

Changed 9 years ago by Garry Yao

Functional test case.

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

Priority: NormalHigh

comment:2 Changed 9 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

Changed 9 years ago by Garry Yao

Attachment: test-editor.patch added

Updated Functiona Test Case

Changed 9 years ago by Garry Yao

Attachment: 3032.patch added

comment:3 Changed 9 years ago by Garry Yao

Keywords: Review? added

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review- WorksForMe added; Review? removed

I can't understand this issue fully. The ticket points to "instanceReady" being fired twice, and the test case is checking for the dirty state.

I've changed the replacebycode sample, making the following for the first instance:

CKEDITOR.replace( 'editor1',
	{
		on :
		{
			instanceReady : function( ev )
				{
					document.title += ' (' + ev.editor.name + ')';
				}
		}
	} );

Everything works properly, and the event is always fired, once only.

Maybe this has been fixed by recent changes. Can you confirm it, giving a real example other than the test case?

comment:5 Changed 9 years ago by Garry Yao

The description is misleading and out-of-date, the problem handled by this ticket is only about:
Event listener for "instanceReady" doesn't grab a correct 'dirtyFlag' value, as the TC described, Since this is a internal error, it's hard to reproduce at UI level.

comment:6 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe removed
Priority: HighNormal

comment:7 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.x

comment:8 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Version: SVN (FCKeditor)CKEditor 3.0 Beta 2

comment:9 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

Milestone CKEditor 3.x deleted

comment:10 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_failedclosed

Expired. TC we currently have points to #9872.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy