Opened 11 years ago

Closed 8 years ago

#3066 closed Bug (invalid)

bug in find replace plugin on releace 2.6.4

Reported by: Avi Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.4
Keywords: Cc:

Description

bug in find replace plugin on releace 2.6.4 ==============================================

when try to find or replace text, when I press the find button to find the next occurrence of the word, there is a javascript error.

The bug happens on Highlight function in fck_replace.html I trucked the code and the source of the error is in : fckdomrange.js on function _UpdateElementInfo line 47 :


this.StartNode = eStart.nodeType == 3 ? eStart : eStart.childNodes[ innerRange.startOffset ] ;


eStart.childNodes[ innerRange.startOffset ] is undefined

Note - it's not happening in all sorts of texts in the editor

In order to reproduce the bug, please follow the following steps

  1. Please insert the following html code into the fck editor

====================== <p><font face="arial" size="2">Avi<br /> Avi <br /> Avi</font></p> <p>&nbsp;</p> ======================

  1. go to design mode
  2. press the find (or replace) button
  3. search the word 'avi'
  4. press the search button 3 times

You get the following error : Line 266 'StartNode.nodeType' is null or not an object

Please try to fix it, as soon as you can. I will appreciate it if you will update me in email

Avi@…

Thanks, Avi

Attachments (2)

FckFindError.JPG (10.6 KB) - added by Avi 11 years ago.
fck find replace error screenshot
FCK Ticket.txt (1.0 KB) - added by Avi 11 years ago.
Ticket

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by Avi

Attachment: FckFindError.JPG added

fck find replace error screenshot

Changed 11 years ago by Avi

Attachment: FCK Ticket.txt added

Ticket

comment:1 Changed 11 years ago by Artur Formella

Component: Project : MediaWiki+FCKeditorGeneral
Keywords: find replace bug removed
Priority: HighNormal

comment:2 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Confirmed with IE8 and Firefox 3.5

comment:3 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy