Opened 11 years ago

Closed 11 years ago

#3067 closed Bug (fixed)

IE : The context menu issues

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: UI : Context Menu Version:
Keywords: Confirmed IE6 Review+ Cc:

Description

With IE6, the following issues have been reported by Martin at #3057:

  1. The size of context menus is incorrect at the first menus are opened.
  2. The size of separators are incorrect.
  3. Scrollbars appear in context menus when the mouse cursor is inside the menus.

Attachments (3)

IE6 + Context Menu.png (47.8 KB) - added by Frederico Caldeira Knabben 11 years ago.
Screenshot showing the shrink issue
3067.patch (954 bytes) - added by Garry Yao 11 years ago.
3067_2.patch (788 bytes) - added by Frederico Caldeira Knabben 11 years ago.

Download all attachments as: .zip

Change History (12)

Changed 11 years ago by Frederico Caldeira Knabben

Attachment: IE6 + Context Menu.png added

Screenshot showing the shrink issue

comment:1 Changed 11 years ago by Frederico Caldeira Knabben

Priority: NormalHigh

Changed 11 years ago by Garry Yao

Attachment: 3067.patch added

comment:2 Changed 11 years ago by Garry Yao

Keywords: Review? added

Fixing size of separators, other two points works for me in current trunk.

comment:3 Changed 11 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

Note that the fix makes the separator being placed over the icons bar, so you can notice the separator line there also, which is wrong.

It is not mentioned in the ticket. The other issues are reproducible in IE6 and IE7 in quirks mode only. That's why we must have different tickets for each issue, otherwise the ticket get blocked until all of them get fixed.

comment:5 Changed 11 years ago by Frederico Caldeira Knabben

The scrollbar issue is being casually fixed at #2996.

Changed 11 years ago by Frederico Caldeira Knabben

Attachment: 3067_2.patch added

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed
Owner: changed from Garry Yao to Frederico Caldeira Knabben
Status: assignednew

Having the scrollbar issue being fixed at #2996, the only remaining thing is the separator size. This new patch fixes it.

comment:7 Changed 11 years ago by Frederico Caldeira Knabben

Status: newassigned

comment:8 Changed 11 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:9 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3331].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy