Opened 11 years ago

Closed 11 years ago

#2996 closed Bug (fixed)

IE6 : Toolbar combos have horizontal scrollbar

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed IE6 Review+ Cc:

Description

In IE6 the toolbar combos panels have horizontal scrollbars.

Attachments (4)

2996.patch (366 bytes) - added by Garry Yao 11 years ago.
2996_2.patch (720 bytes) - added by Frederico Caldeira Knabben 11 years ago.
ie6.jpg (91.5 KB) - added by Garry Yao 11 years ago.
Screenshot of IE6
2996_3.patch (782 bytes) - added by Frederico Caldeira Knabben 11 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 11 years ago by Frederico Caldeira Knabben

Priority: NormalHigh

Changed 11 years ago by Garry Yao

Attachment: 2996.patch added

comment:2 Changed 11 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

comment:3 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Owner: changed from Garry Yao to Frederico Caldeira Knabben
Status: assignednew

Holly hack! But it looks like the problem is instead located in the auto-height calculation made in the floatpanel plugin.

I've just coded something that should work for it.

Changed 11 years ago by Frederico Caldeira Knabben

Attachment: 2996_2.patch added

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed
Status: newassigned

Changed 11 years ago by Garry Yao

Attachment: ie6.jpg added

Screenshot of IE6

comment:5 Changed 11 years ago by Garry Yao

Keywords: Review- added; Review? removed

I see no difference with this screenshot.

Changed 11 years ago by Frederico Caldeira Knabben

Attachment: 2996_3.patch added

comment:6 in reply to:  5 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed

Replying to garry.yao:

I see no difference with this screenshot.

Sorry, I've confused the toolbar combos with the context menu. The new patch fixes the combo issues. I'll move the previous patch to another ticket.

comment:7 Changed 11 years ago by Frederico Caldeira Knabben

It looks like this fix also fixes the scrollbar issue in the context menu.

comment:8 Changed 11 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:9 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3330].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy