Opened 10 years ago

Closed 10 years ago

#3075 closed Bug (fixed)

plugin:wysiwyg broken on insertHtml

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Review+ Cc:

Description (last modified by Garry Yao)

After introducing the HTML Parser Filter system, method like protectHtml should be removed, which in this case cause JavaScript error.

Attachments (3)

test-insertHtml.patch (2.7 KB) - added by Garry Yao 10 years ago.
Unit Test Case
3075.patch (3.6 KB) - added by Garry Yao 10 years ago.
3075_2.patch (605 bytes) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by Garry Yao

Attachment: test-insertHtml.patch added

Unit Test Case

Changed 10 years ago by Garry Yao

Attachment: 3075.patch added

comment:1 Changed 10 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

comment:2 Changed 10 years ago by Garry Yao

Description: modified (diff)

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

The reason for having those functions outside the init scope is to avoid them being recreated for each editor instance. Why changing things that are not related to this ticket? Please leave them in their original place, or give it a good reason why.

Changed 10 years ago by Garry Yao

Attachment: 3075_2.patch added

comment:4 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

Fred you are right, we don't need establish this closure.

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:6 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [3176]. Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy