Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3076 closed Bug (fixed)

Link shows "RTENOTITLE" in FCKeditor

Reported by: Lei Jiang Owned by:
Priority: Must have (possibly next milestone) Milestone:
Component: Project : MediaWiki+FCKeditor Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Cc: paul irish

Description

I am using Mediawiki 1.14.0 + FCKeditor. The FCKeditor extension is download from SVN, and fckeditor is 2.6.4.

When I open a existing article to start editing, I find the links in that article has been replaced with "RTENOTITLE". When I click "Wikitext" button to switch to Wikitext mode, the link has been replaced with something like "/wiki/index.php/My article title".

How to avoid this?

Thanks!

Change History (11)

comment:1 Changed 11 years ago by Artur Formella

Keywords: Pending added
Milestone: FCKeditor 2.6.5
Priority: HighNormal

Could you provide sample article to show the bug?

comment:2 Changed 11 years ago by Lei Jiang

Priority: NormalHigh

I later found that this problem does not occur when the link is in English. When I write the link in Simplified Chinese, this problem occur.

For example, in any page, when I write 测试?, then save the page, and click the link to enter the page, and you will find that 测试? become RTENOTITLE.

comment:3 Changed 11 years ago by Etienne Massip

Got the same pb with accent "é".

As you said, this happens only if the target page exists.

comment:4 Changed 11 years ago by paul irish

Cc: paul irish added
Version: FCKeditor 2.6.4SVN

I'm seeing this issue too:

http://gyazo.com/0e8b295aa250a118a1c145c6b0710627.png

Version: FCKeditor+MW svn trunk, MW 1.14alpha

I'm actually seeing two issues in here:

  1. addition of RTENOTITLE to title of pages
    1. apparently not added when & is changed to &
  2. addition of /wiki/ path that breaks the links

comment:5 Changed 11 years ago by Wiktor Walc

Keywords: Confirmed added; Pending removed

comment:6 Changed 11 years ago by Wiktor Walc

Resolution: fixed
Status: newclosed

Fixed with [3224].

Let me know if you experience any problems with it.

comment:7 Changed 11 years ago by Etienne Massip

Works fine for me now. Great job, thanks !

comment:8 Changed 11 years ago by Etienne Massip

A new strange behavior has appeared now (may also have been caused by another recent fix I svn-updated in the same time) : by pushing the "Wikitext" button, the result displayed is now correct, but by pushing it one more time I get a "Loading Wikitext. Please wait..." message and...nothing more, it never loads back the WYSIWYG content anymore.

comment:9 Changed 11 years ago by Wiktor Walc

Clear browser cache.

If that didn't help, use Firefox + Firebug to inspect the AJAX calls, let me know if you see anything wrong there.

comment:10 Changed 11 years ago by Etienne Massip

Well, clearing browser cache changes nothing.

There is an ajax POST query with ends with http success code 200 and which returned data is somewhat looking like the html code I get when I inspect the original iframe content, except that :

  • there is not yet "_fcksavedurl" attribute in "a", just some "_fcknotitle" valued with "true"
  • a very few minors markups like "tbody" or "br" are missing that must be automatically added by fck or ff or firebug, dunno

Looks like either it can't parse response html or it can't load it into the iframe.

comment:11 Changed 11 years ago by Etienne Massip

Ok, I found this one, this is a Firebug bug, ahah :

https://bugzilla.mozilla.org/show_bug.cgi?id=482293[[BR]]

http://groups.google.com/group/firebug/browse_thread/thread/d3e264da827e2a9[[BR]]

etc.

You can mark the ticket as resolved !

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy