Opened 11 years ago

Closed 10 years ago

#3084 closed Bug (fixed)

Spellchecker displays (broken) HTML at the text field

Reported by: Denilson Figueiredo de Sá Owned by: WebSpellChecker.net
Priority: Normal Milestone:
Component: UI : Spell Checker Version: FCKeditor 2.6.4
Keywords: Review? Cc: WebSpellChecker.net

Description (last modified by Frederico Caldeira Knabben)

The spellchecker dialog shows a small piece of broken HTML at the text panel. It shouldn't display HTML, and shouldn't even display broken one. See attached screenshot.

How to reproduce:

  1. Go to http://www.fckeditor.net/demo
  2. Click on the FCKeditor text area to place the cursor at the end of the default demo text.
  3. Press Enter, and type "ñ". This is the same as ñ, which is a common character in Spanish language (although I don't speak Spanish).

Notice: I've typed this char by typing ~ followed by n. In my keyboard layout (which is us_intl, or US International), ~ key is a deadkey.

  1. Click on spellchecker button.

Tested with Firefox 2.0.0.19 on Linux.

Attachments (1)

fckeditor.png (64.1 KB) - added by Denilson Figueiredo de Sá 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by Denilson Figueiredo de Sá

Attachment: fckeditor.png added

comment:1 Changed 11 years ago by Artur Formella

Keywords: Confirmed added
Version: CKEditor 3.0 Beta

Confirmed in FCKeditor and CKEditor

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Cc: WebSpellChecker.net added
Description: modified (diff)

comment:3 Changed 11 years ago by WebSpellChecker.net

Owner: set to WebSpellChecker.net
Status: newassigned
Version: CKEditor 3.0 BetaFCKeditor 2.6.4

The problem is inside the SpellChecker.net application and SpellChecker.net is going to fix it.

comment:4 Changed 10 years ago by WebSpellChecker.net

Keywords: Review? added; Confirmed removed
Resolution: fixed
Status: assignedclosed

Fixed on SpellChecker.net side.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy