Opened 10 years ago

Closed 8 years ago

#3129 closed Bug (worksforme)

Selection sensitive commands state after switch mode is incorrect

Reported by: Garry Yao Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (CKEditor) - OLD
Keywords: HasPatch Cc:

Description (last modified by Garry Yao)

E.g. RichCombo marked list item state is not reset on mode switch, reproduce by :

  1. Open the replace by code example page;
  2. Open a combo and select a item;
  3. Switch to 'source' mode and then switch back;
    • Actual Result: Still marked selection result from previous.

Attachments (2)

3129.patch (2.4 KB) - added by Garry Yao 10 years ago.
3129_2.patch (2.4 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 10 years ago by Garry Yao

Description: modified (diff)
Keywords: Confirmed Review? added
Owner: set to Garry Yao
Status: newassigned
Summary: RichCombo state after switch mode is incorrectSelection sensitive commands state after switch mode is incorrect

This patch force all the selection sensitive commands to be reset with a simple way when switching to 'source' mode and back.

Changed 10 years ago by Garry Yao

Attachment: 3129.patch added

Changed 10 years ago by Garry Yao

Attachment: 3129_2.patch added

comment:2 Changed 10 years ago by Garry Yao

Fix to work with [3227].

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.0CKEditor 3.1

comment:4 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Version: SVN (FCKeditor)CKEditor 3.0 Beta 2

comment:5 Changed 10 years ago by Tobiasz Cudnik

Keywords: Pending added

Cannot reproduce this neither on IE 8, FF 3.5 and Chromium. Seems that fix isn't needed now ?

comment:6 Changed 10 years ago by Garry Yao

@Tobias: I suspect we differs from the description that "selection result" is misleading while it means the selected item indicated by the inline combo label.

comment:7 Changed 9 years ago by Garry Yao

Owner: Garry Yao deleted
Status: assignednew

comment:8 Changed 9 years ago by Garry Yao

Keywords: HasPatch added; Confirmed Review? removed
Version: 3.0 Beta 2SVN (CKEditor)

comment:9 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.1CKEditor 3.2

comment:10 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2CKEditor 3.3

comment:11 Changed 9 years ago by Garry Yao

Milestone: CKEditor 3.3CKEditor 3.x

comment:12 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

Milestone CKEditor 3.x deleted

comment:13 Changed 8 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: pendingclosed

This is not any more an issue with the current trunk.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy