Opened 11 years ago

Closed 11 years ago

#3132 closed Bug (fixed)

Tab and Shift-Tab is skipping elements

Reported by: Martin Kou Owned by: Martin Kou
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Oracle Cc: Senthil

Description

I can't reproduce this problem locally but it's seen in Senthil's demonstration this evening:

  1. Give every input element and link in a form, which includes CKEditor as an input element, ascending tabindex-es.
  2. Put the focus into CKEditor editing area.
  3. Press Tab.
  4. The focus goes to one tab index after the element that should receive the focus.

Attachments (2)

Tab_Issue.html (3.5 KB) - added by Senthil 11 years ago.
Sample file to reproduce the tab and shift issue
Tab_Issue.2.html (2.4 KB) - added by Martin Kou 11 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by Frederico Caldeira Knabben

Can you please add a simple sample page for this?

comment:2 Changed 11 years ago by Martin Kou

I can't reproduce the issue locally. But I remember the links in Senthil's demo yesterday in Firebug were grayed out - which indicates the <a> tags are not visible (but their child nodes are). I'm suspecting the CKEDITOR.dom.element::isVisible() function is returning false for those <a> elements.

I need to contact Senthil today to see what's really at fault here.

comment:3 Changed 11 years ago by Martin Kou

Resolution: fixed
Status: newclosed

I've proved conclusively in tonight's meeting with Senthil that it's the hotkey and focus handling logic on their side that's causing the problem.

Changed 11 years ago by Senthil

Attachment: Tab_Issue.html added

Sample file to reproduce the tab and shift issue

comment:4 Changed 11 years ago by Senthil

Priority: NormalHigh
Resolution: fixed
Status: closedreopened

I am able to reproduce the reported and the following issues using the standalone html file (attached for the reference).

Following issues are reproducible by using the standalone html file attached here.

Internet Explorer 7: Tab and Shift Tab issue

  1. Tab through the test page(attached) elements one by one, once we reached the editor area and press tab it skips the next element and cursor reasches the next to next element for the editor.
  2. Tab through the test page(attached) elements one by one, once we reached the editor area and press shift tab it skips the previous element and cursor reasches the previous to previous element for the editor.

Fire Fox 3: Tab and Shift Tab issue

  1. Tab through the test page(attached) elements one by one, once we reached the editor area and press shift tab it doesn't do anything.

Safari 3: Tab and Shift Tab issue

  1. Tab and Shift Tab is not able to reach the editor area at all. Thus user can't reach the editor area using tab or shift tab.

Please fix this as early as possible since it is critical for the accessibility.

Changed 11 years ago by Martin Kou

Attachment: Tab_Issue.2.html added

comment:5 Changed 11 years ago by Martin Kou

The original test case from Senthil doesn't work - the sample format is incorrect. So I'm posting one that works.

The issue can be reproduced only with the compressed CKEditor code made by the releaser. So it's actually the releaser that's breaking things.

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: reopenedclosed

This issue has been fixed by #3212.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy