Opened 9 years ago

Closed 9 years ago

#3141 closed Bug (duplicate)

Block styles incorrect with full selection

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Firefox Confirmed Cc:

Description

Reproducing Procedures

  1. Open the replace by code example page;
  2. Make document content and selection as following:
    ^<h1>text</h1>^
    
  3. Open 'Format combo and select 'h2';
    • Actual Result : End with an extra block appended.
      <h2>
      	text</h2>
      <h2>
      </h2>
      

Change History (4)

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe added

I'm not able to reproduce it. Can you confirm it has been fixed?

comment:2 Changed 9 years ago by Garry Yao

Keywords: Firefox added; WorksForMe removed

It's a not fixed at least on FF.

comment:3 Changed 9 years ago by Garry Yao

Keywords: Confirmed added
Owner: set to Garry Yao
Status: newassigned

The bug was caused by bookmark nodes has also been counted by domIterator, which is wrong. It's indented to be fixed at #3352.

comment:4 Changed 9 years ago by Garry Yao

Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy