Opened 9 years ago

Closed 9 years ago

#3157 closed Bug (fixed)

Smiley plugin causes browser to hang

Reported by: Damian Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed IBM Review+ Cc:

Description

Most browsers hang or crash when accessing the smiley feature on a subsequent instance of the editor.

Steps to reproduce:

  1. Open Ajax example
  2. Use smiley plugin to add smiley to the document.
  3. Destroy the editor
  4. Create new editor
  5. Attempt to add a smiley

Result: Most browser will hang or crash at this point. Possibly related to a recursion issue.

Attachments (1)

3157.patch (633 bytes) - added by Garry Yao 9 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by Garry Yao

Keywords: Confirmed added
Owner: set to Garry Yao
Status: newassigned

comment:2 Changed 9 years ago by Garry Yao

Keywords: Review? added

The problem is caused by dialog registration system, which is independent of the editor instances.

Changed 9 years ago by Garry Yao

Attachment: 3157.patch added

comment:3 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:4 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [3231].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy