Opened 11 years ago

Closed 11 years ago

#3208 closed Bug (fixed)

IE Focus issue with Ajax example

Reported by: Damian Owned by: Martin Kou
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IBM Review- Pending Cc:

Description

After opening the ajax example in IE6 and creating the editor instance for the first time, it is not possible to focus in the editing area.

Attachments (1)

3208.patch (600 bytes) - added by Martin Kou 11 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 11 years ago by Damian

Priority: NormalHigh

comment:2 Changed 11 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Changed 11 years ago by Martin Kou

Attachment: 3208.patch added

comment:3 Changed 11 years ago by Martin Kou

Keywords: Review? added

The editing areas generated by the sample isn't really non-editable - but you need to click at the right place in the editing frame (near the top of it, where the first row of the first paragraph is supposed to be) because the <body> tag in the editing frame isn't expanded.

The submitted patch expands the <body> inside the editable frame so that it can be more easily focused.

comment:4 Changed 11 years ago by Damian

The suggested patch is useful as many users don't realize they need to click in a specific area of the editor to focus it.

The actual problem is that the edit area cannot gain focus, even on the narrow row that you mentioned. It is not easy to reproduce. One method that seems to increase the chances of reproducing it is to open a new IE window, clear browser cache, reload the sample and create the editor. I have reproduced it on today's nightly build in both IE6 and IE7.

This problem seems to occur more frequently in our application than on the sample page.

comment:5 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

@martinkou, the thing you are trying to fix is #1659. Feel free to add a ticket there, if you think it will fix it... but be sure to have a look a the comments there first.

We should instead try to reproduce the problem as described by damo.

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Pending added

I'm finding it really difficult to reproduce. It just works for me.

@damo, do you have any hints on how to see the problem here? Maybe a tc page?

comment:7 Changed 11 years ago by Martin Kou

It works for me as well.

comment:8 Changed 11 years ago by Frederico Caldeira Knabben

Priority: HighNormal

comment:9 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

It looks like it's not an issue anymore. Please feel free to reopen it with more information if I'm wrong.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy