Opened 11 years ago

Closed 11 years ago

#3209 closed Bug (fixed)

V3 : Implement full RTL support for the UI

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed Review+ Cc:

Description

Currently, the UI doesn't offer full support for RTL.

Attachments (1)

3209.patch (31.2 KB) - added by Frederico Caldeira Knabben 11 years ago.

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by Frederico Caldeira Knabben

Attachment: 3209.patch added

comment:1 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review? added
Status: newassigned

comment:2 Changed 11 years ago by Martin Kou

Keywords: Review- added; Review? removed

Review- because:

  1. Dialog styles (esp. the dialog frame) are broken in RTL mode.
  2. The ui_languages sample doesn't work in IE.
  3. Empty spaces in dialog title are not draggable in IE.

comment:3 in reply to:  2 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed

Replying to martinkou:

  1. Dialog styles (esp. the dialog frame) are broken in RTL mode.

The problem is that patch can't include binary files on it, so you have one of the new ones (renamed) missing. We;ll not have this problem after commit, I promise :)

  1. The ui_languages sample doesn't work in IE.

That's a limitation in the current sample system, not the sample file itself. We'll handle it in another ticket.

  1. Empty spaces in dialog title are not draggable in IE.

This behavior is by design, caused by a limitation in the browser. Actually, it's possible to drag them by clicking on the title text. We'll handle it with another ticket.

comment:4 Changed 11 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:5 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3305].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy