Opened 9 years ago

Closed 9 years ago

#3266 closed Bug (fixed)

Minimize the usage of the _cke_expando attribute

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed Review+ Cc:

Description

Our DOM API currently forces the creation or the _cke_expando property for every DOM object created.

In IE, this property becomes an attribute into the DOM. So, this situation is causing a huge performance impact in the code.

Attachments (1)

3266.patch (5.1 KB) - added by Frederico Caldeira Knabben 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by Frederico Caldeira Knabben

Attachment: 3266.patch added

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review? added
Status: newassigned

We are creating that expando property in the object constructor just because of the CKEDITOR.event object. There is no need of it, and a much sleek solution is proposed in this patch.

comment:2 Changed 9 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:3 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3322].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy