Opened 11 years ago

Closed 8 years ago

#3269 closed Bug (invalid)

FCKEditor for Mediawiki

Reported by: Niels Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.6.4 Beta
Keywords: Cc:

Description

Once an image is added, if you switch back to wikitext mode, and then switch back to rich editor mode, the image disappears, and the text [[Image:]] is all that remains. This happens reliably, though it's not clear to me if it's event-driven or based on some sort of count somewhere.

Change History (15)

comment:1 Changed 11 years ago by Niels

I wish I could change the title to Images drop out in FCKeditor for Mediawiki

comment:2 Changed 11 years ago by Artur Formella

Component: GeneralProject : MediaWiki+FCKeditor
Keywords: mediawiki image images pictures removed
Milestone: CKEditor 3.x

comment:3 Changed 11 years ago by Wiktor Walc

Keywords: Pending WorksForMe added

Copied from #3270:

"looking in mediawiki/fckplugin.js, I can see where the image is constructed (starting at line 524, with "imgName"). That all seems okay. I wonder if it happens when you try to recover the _fck_mw_filename, but if that variable hasn't been set, then there's nothing for the mediawiki/fckplugin.js to construct with.

I don't know. I'm groping around in the dark here."

Are you running the latest version of FCKeditor extension available here: http://mediawiki.fckeditor.net/ ? Which MediaWiki version are you using? Does it happen in all browsers?

comment:4 Changed 11 years ago by Niels

Are you running the latest version of FCKeditor extension?

You mean version 3368 in SVN? Not sure, how would I check? The "About FCKEditor" message says "version [development] Build [dev]"

It works on a remote wiki: http://navyhpsp.net/wiki/FCKEditorImageTest

It breaks after a couple of cycles on localhost: http://localhost/wiki/FCKEditorImageTest

comment:5 Changed 11 years ago by Niels

Steps to reproduce on localhost:

1) upload image 2) insert image into article 3) Switch to wikitext view 4) Switch back to richtext view 5) Switch to wikitext view: broken

or

1) upload image 2) insert image into article 3) Save 4) Edit 5) Switch to wikitext view: broken

comment:6 in reply to:  5 ; Changed 11 years ago by Peter Green

I can reproduce reliably on 2.6.4 B21629, MediaWiki 1.14.0 using IE8. Will test on other browsers tonight.

comment:7 in reply to:  6 Changed 11 years ago by Peter Green

Tested on Firefox and Chrome last night - same behaviour.

comment:8 Changed 11 years ago by Niels

Same behavior in Safari 4 beta

comment:9 Changed 11 years ago by Wiktor Walc

I have tried a vanilla MW 1.14.0 installation with just the FCKeditor extension enabled and $wgEnableUploads set to true (on Chrome, IE7/IE8, FF2, FF3 with no extra extensions).

The FCKeditor extension has been downloaded here: http://mediawiki.fckeditor.net/nightly/svn/mediawiki_fckeditor_ext_N.zip

I am unable to reproduce it locally (WAMP) - any hints on how to trigger this bug? Maybe you're using file with a strange name or something like that?

comment:10 Changed 11 years ago by Niels

Also happens, reliably, in Opera (9.26 . . . upgrading to 9.64, we'll see).

It happens with every [[Image:]] tag, regardless. JPG, SVG, GIF, doesn't matter. Just follow the steps I outlined above. I use this instance of mediawiki with fckeditor hundreds of times a day, because it's where I keep my medical school notes. It *doesn't* happen with galleries.

FWIW I'm running this on a Mac. I'll try running it on a local linux box tonight. I'll also try running it on across a LAN instead of internet.

comment:11 in reply to:  6 Changed 11 years ago by Peter Green

Replying to elsandalos:

I can reproduce reliably on 2.6.4 B21629, MediaWiki 1.14.0 using IE8. Will test on other browsers tonight.

For those wanting to replicate this, i am using the current version of the turnkey linux mediawiki appliance, but i have upgraded the included FCKEditor with 2.6.4 B21629 to get rid of another bug.

http://www.turnkeylinux.org/appliances/mediawiki

comment:12 Changed 11 years ago by Niels

I'm using 2.6.4 "trunk" from SVN, checked out either yesterday or the day before (can't recall, I'm running on not much sleep working in the ICU), and MediaWiki/trunk, checked out at the same time. The latest revision in the svn.fckeditor.net repo at the time was 3368. So I downloaded as close to that as possible. (How do I get the build number?)

comment:13 Changed 11 years ago by Niels

Upgraded my OS X mediawiki to trunk revision 49359. Image handling still breaks on localhost.

I installed Ubuntu's 8.10 mediawiki package and added fckeditor from svn (mediawiki trunk, fckeditor 2.6.4), and it *works*. Hmmmmmmmmmmmm . . .

Why would this break on localhost in three different versions of mediawiki under OS X and four different browsers, but it works in localhost LAMP and WAMP? The server is just sending the ck package to the client, right? Or is there server-side work being done too? FWIW I'm using apache2 and php5 from macports.

comment:14 Changed 11 years ago by David

some of you may find this helpful

http://dev.fckeditor.net/ticket/2624

I had the same issue and it was fixed with the above solution , though imo it's a temp fix as you idealy want to leave on the clean html settting i would think

comment:15 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible.

Last edited 8 years ago by Jakub Ś (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy