Opened 11 years ago

Closed 8 years ago

#3281 closed Bug (invalid)

"Special Tag Properties" interface deletes tabs and blank spaces

Reported by: blitzschlagman Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.5.1
Keywords: Cc: ikoch@…

Description

The FCKeditor/MediaWiki "Special Tag Properties" interface for adding and editing "special tags" deletes tabs and blank spaces at the beginning of the lines, i.e. when adding and editing xml-code (which contains blank spaces or tabs at the beginning of the lines).

This happens only in IE (7, 8) when a page is re-edited. No problems with Firefox.

"Extension:SyntaxHighlight GeSHi" for proper source code formatting installed.

Before:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<verzeichnis>
     <titel>Wikipedia Städteverzeichnis</titel>
     <eintrag>
          <stichwort>Genf</stichwort>
          <eintragstext>Genf ist der Sitz von ...</eintragstext>
     </eintrag>
     <eintrag>
          <stichwort>Köln</stichwort>
          <eintragstext>Köln ist eine Stadt, die ...</eintragstext>
     </eintrag>
</verzeichnis>

After:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<verzeichnis>
 <titel>Wikipedia Städteverzeichnis</titel>
 <eintrag>
 <stichwort>Genf</stichwort>
 <eintragstext>Genf ist der Sitz von ...</eintragstext>
 </eintrag>
 <eintrag>
 <stichwort>Köln</stichwort>
 <eintragstext>Köln ist eine Stadt, die ...</eintragstext>
 </eintrag>
</verzeichnis>

Attachments (1)

3281.patch (18.0 KB) - added by Wiktor Walc 11 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by blitzschlagman

Cc: ikoch@… added

comment:2 Changed 11 years ago by Artur Formella

Keywords: Confirmed added
Priority: HighNormal

Changed 11 years ago by Wiktor Walc

Attachment: 3281.patch added

comment:3 Changed 11 years ago by Wiktor Walc

Keywords: Review? added

Could you check this patch and let me know whether everything works as expected?

The SVN instructions are available here: http://mediawiki.fckeditor.net/index.php/SVN_Instructions (the easiest solution is to use TortoiseSVN if you're working on Windows)

comment:4 Changed 11 years ago by blitzschlagman

Unfortunately the patch could not be installed properly (got an error message).

We modified the code of the corresponding files by hand and now everything works as expected (tested with version 2.6.4 Build 21629).

We have noticed only one minor bug: With every preview of the Wiki-page a <br> is generated after the </source> tag.

Btw.: Will this patch be integraded in the extension-repository?

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

Status: reviewassigned

comment:6 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: assignedclosed

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy