Opened 10 years ago

Closed 10 years ago

#3290 closed New Feature (fixed)

Implement collapse toolbar feature

Reported by: Martin Kou Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Toolbar Version: SVN (CKEditor) - OLD
Keywords: Oracle Review+ Confirmed Cc: Senthil

Description

The collapse toolbar button is missing in CKEditor trunk.

Attachments (1)

3290.patch (6.0 KB) - added by Frederico Caldeira Knabben 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by Alfonso Martínez de Lizarrondo

I've always wondered why it's there that feature.

As far as I can remember, only Netscape did provide collapsible toolbars, and so, every time I see that grippy it brings bad memories :)

I can understand the wish to have the toolbar visible/hidden and an API to switch that (onblur->toolbar goes away), as well as the ability to switch between full toolbar and simple toolbar, but the collapse just eludes me.

comment:2 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Owner: changed from Martin Kou to Frederico Caldeira Knabben
Status: assignednew

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 3290.patch added

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review? added

Due to the new (optimize and fast) toolbar structure we have in V3, we are not anymore able to have the collapse bar at the left of the toolbar. This patch proposes an elegant solution for it, by placing a small bottom at the toolbar end.

The binary files related to this patch have been committed with [3398].

comment:5 in reply to:  1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added
Status: newassigned

Replying to alfonsoml:

the collapse just eludes me

I agree alfonsoml... but it looks like users (and developers) got used to have that feature and aim to still have it when upgrading. The "start expanded" setting may give some sense still having it, but in any case, this is one of those features that don't hurt (and can be easily disabled).

comment:6 Changed 10 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3401].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy