Opened 10 years ago

Closed 7 years ago

#3350 closed Task (invalid)

Mediawiki: template menu should start on Manual tab

Reported by: Niels Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.6.4
Keywords: Cc:

Description

This is a defaults-influencing-user-experience issue: conceptually, you're using templates in order to not *avoid* editing. Setting the "manual" tab would save a lot of clicks over the long term.

Change History (3)

comment:1 Changed 10 years ago by Artur Formella

Keywords: Confirmed added; templates submenu edit manual removed
Milestone: CKEditor 3.0

I don't know if that's a good idea. Manual tab is empty at the start, we need to download the combo's content using AJAX and it takes time.

One idea is to start on Manual tab, but it is empty in most cases and we don't know it until AJAX content is ready.

Other idea is to switch to Manual tab if there is some content (when combo is ready) - but switching 10seconds after loading can be annoying.

Third idea (I think the best one) is to remember the last opened tab.

comment:2 Changed 10 years ago by Niels

remember the last opened tab.

perfect.

comment:3 Changed 7 years ago by Jakub Ś

Resolution: invalid
Status: confirmedclosed

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy