Opened 10 years ago

Closed 10 years ago

#3351 closed Bug (fixed)

Combo list item marking not working

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed Review+ Cc:

Description

The panel list inside combo is not correctly marking those selected items.

Attachments (2)

3351.patch (740 bytes) - added by Garry Yao 10 years ago.
3351_2.patch (778 bytes) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by Garry Yao

Attachment: 3351.patch added

comment:1 Changed 10 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

comment:2 Changed 10 years ago by Martin Kou

Keywords: Review- added; Review? removed

Please use

.cke_panel_listItem.cke_selected a 

instead.

The .cke_selected class is purely there to indicate a state - other UI elements may use this state in the future.

comment:3 Changed 10 years ago by Garry Yao

I guess we should avoid 'multiple selector' as in #3021.

comment:4 Changed 10 years ago by Martin Kou

The multiple selector is ok in this case because we're always having a <!doctype html> inside the panel iframe. So it's always standards mode.

Changed 10 years ago by Garry Yao

Attachment: 3351_2.patch added

comment:5 Changed 10 years ago by Garry Yao

Keywords: Review? added; Review- removed

comment:6 Changed 10 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:7 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [3390].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy