Opened 10 years ago

Closed 10 years ago

#3418 closed Bug (invalid)

Tabs in Flash and Find/Replace dialogs not keyboard accessible

Reported by: Damian Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: Accessibility Version:
Keywords: IBM Cc:

Description

It is not possible to switch tabs in the Flash and Find/Replace dialogs using the keyboard.

Attachments (1)

3418.patch (644 bytes) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by Artur Formella

Keywords: Confirmed added

The same problem with all tabs in all dialogs.

Changed 10 years ago by Garry Yao

Attachment: 3418.patch added

comment:2 Changed 10 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

Trigger the access key on keydown event to avoid conflicting with browser native shortcut keys

comment:3 Changed 10 years ago by Garry Yao

The current definition of 'access key' is not complete with the following perspective:

  1. Access keys are missing for many dialog fields;
  2. There's no access key prompt in label/title;
  3. It's better to have a access key for 'switching between dialog pages' besides assigning each tab with a single key, e.g. 'Ctrl-Tab'.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

Sorry... there must be some missing information here. Check out the Accessibility documentation:
http://docs.fckeditor.net/CKEditor_3.x/Users_Guide/Accessibility

Basically:

  • ALT+F10 to move the focus to the tabs.
  • At this point, TAB/SHIFT+TAB or ARROWS to change the tab.
  • ENTER to select the TAB and move the focus to its contents.

Am I missing something?

comment:5 Changed 10 years ago by Damian

You are right, this is not a bug. The mechanism for using ALT+F10 to get to the tabs section was not known to the tester at the time. I propose closing the bug as invalid.

comment:6 Changed 10 years ago by Garry Yao

Keywords: Confirmed Review- removed
Resolution: invalid
Status: assignedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy