Opened 11 years ago

Closed 10 years ago

#3417 closed Bug (fixed)

JAWS does not read the first toolbar item after switching focus to toolbar

Reported by: Damian Owned by: Martin Kou
Priority: Normal Milestone: CKEditor 3.0
Component: Accessibility Version:
Keywords: IBM Review+ Cc:

Description

After using ALT+F10 to switch focus to the toolbar, JAWS does not read out the first item that is selected.

Attachments (5)

3417.patch (717 bytes) - added by Martin Kou 11 years ago.
3417_2.patch (580 bytes) - added by Martin Kou 11 years ago.
3417_3.patch (2.9 KB) - added by Martin Kou 10 years ago.
3417_4.patch (2.9 KB) - added by Martin Kou 10 years ago.
3417_5.patch (534 bytes) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 11 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Changed 11 years ago by Martin Kou

Attachment: 3417.patch added

comment:2 Changed 11 years ago by Martin Kou

Keywords: Review? added

comment:3 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

I was able to confirm this issue in IE only. It works for me with FF3 before applying the patch, and the patch fixes it for IE. I was wondering if the gecko special case is really needed here.

Changed 11 years ago by Martin Kou

Attachment: 3417_2.patch added

comment:4 Changed 11 years ago by Martin Kou

Keywords: Review? added; Review- removed

comment:5 Changed 11 years ago by Martin Kou

Wait... After I've rebooted and started JAWS again, the problem is appearing in FF3 again. So I think FF's fix in 3417.patch is still needed.

comment:6 Changed 11 years ago by Martin Kou

Ok, I've tested it a few more times. Seems that's caused by the virtual cursor again, and the Gecko fix in 3417.patch doesn't fix anything at all. So please review 3417_2.patch instead.

comment:7 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:8 Changed 11 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [3484].

Click here for more info about our SVN system.

comment:9 Changed 10 years ago by Damian

Resolution: fixed
Status: closedreopened

comment:10 Changed 10 years ago by Martin Kou

Keywords: Review+ removed

I've tried Fred's suggested approach to fix this ticket yesterday, but it doesn't work. Still finding other solutions.

comment:11 Changed 10 years ago by Martin Kou

Keywords: Review? added

Added a hack based on ARIA live regions for Firefox 3.

Changed 10 years ago by Martin Kou

Attachment: 3417_3.patch added

comment:12 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

It looks like things work well with IE before the patch. The patch is still good because it properly assigns the "button" role to the buttons, making them ready properly.

In FF instead, I've noticed that things work well when the user is in "editing mode" (after hitting ENTER in the editing area to activate it). The source button is always announced properly.

In FF, it may instead be not announced only if we're not in editing mode. this is random though. The patch creates a strange effect in this sense, as it announces the source button twice on some cases.

As "editing mode" is a basic requirement into the editor, we may consider simply fixing the button role.

Changed 10 years ago by Martin Kou

Attachment: 3417_4.patch added

Changed 10 years ago by Martin Kou

Attachment: 3417_5.patch added

comment:13 Changed 10 years ago by Martin Kou

Keywords: Review? added; Review- removed

3417_4.patch sets the live region to rude mode - this means the live region's announcements will interrupt and supersede any previous announcements. This fixes the duplicated "Source Source" announcements, but it will also interrupt the "Alt-F10" key press announcement. So you'll have "Al- (sudden pause) Source" announced.

3417_5.patch simply fixes the button role and nothing more.

comment:14 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

R+ for 3417_5.patch. I'm quite unsure about the acceptance of the 3417_4.patch behavior.

comment:15 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: reopenedclosed

Fixed with [3700].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy