Opened 11 years ago

Closed 10 years ago

#3443 closed Bug (worksforme)

Bug: Safari: Loses Formatting

Reported by: spgard Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.4
Keywords: Safari Cc:

Description

Using http://www.fckeditor.net/demo on a MacBook OS X v10.4.11 with Safari 3.1.2 (4625.22). Repeatable in the nightly build (as of 24 Apr 2009).

Steps to reproduce:

  • Delete the default text in the demo.
  • Type in "This is text." (not the quotes)
  • Highlight the text and change it to X-Large font and give it a color.
  • Switch to Source view and back to Design view (all is still good).
  • Highlight "This is text." Change it to say something new.
  • Switch to Source view (note the spans have been combined, the font changes from a point size to a pixel size, and the Apple-style-span class is added). Switch back to Design view. Color and size formatting is lost.

You can get this same effect of lost formatting when saving rather than switching between Source and Design view.

Change History (3)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Safari added

I'm afraid this is an intrinsic WebKit "feature", which we would be hardly able to workaround. We need to report it at the WebKit bugzilla.

comment:2 Changed 10 years ago by Alfonso Martínez de Lizarrondo

I can't reproduce it in 4.0.1

They might have fixed it long ago, so it's not worth filing to WebKit if that's the case.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: newclosed

Thanks for the update on this Alfonso. It's good to hear that WebKit got fixed. We'll not do further investigations.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy