Opened 11 years ago

Closed 10 years ago

#3444 closed Bug (invalid)

When save page or preview, the image change into codes

Reported by: Jimmyst Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Recently I use MEDIAWIKI to build an inter-use-only website, in the solaris10 enviroment. The server enviroment for mediawiki is:MediaWiki 1.14.0+PHP 5.2.6-2 (apache2handler)+MySQL 5.x, and I integrated the FCKeditor into the mediawiki. When using the "Image Button" of the FCKEditor toolbar, I can upload or add an existing image in my article from the file browser. It looks alright in the text editor. However, the minute I click "Show Preview" or "Save", the image is converted into text : <input type="image" width="640" height="480" src="/userfiles/example.jpg"></input>. If I go to wikitext, the line has been converted to : &lt;input type="image" height="480" width="640" src="/userfiles/example.jpg"&gt;&lt;/input&gt; The FCKeditor I use is downloaded from the link below:http://mediawiki.fckeditor.net/nightly/svn/mediawiki_fckeditor_ext_N.tar.gz Can anyone tell me what's the cause of this? Or how can I fix it? Thank you.

Change History (1)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Component: Server : PHPGeneral
Resolution: invalid
Status: newclosed

You're using the "Image Button" instead of the "Image" option in the toolbar. You should remove the first one, having only the later available.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy